Portfolio Support Compatibility Guide for Versions 1.x and 2.x