Upgrading to Universal Core Client 6.1.6 or higher