Problem
We have catalogs from Portfolio 11 or older in the .fdb format that are having trouble running in Portfolio 3.x.x
Environment
This issue can occur on Portfolio 3 installed on any supported operating system
Cause
The previous format for Portfolio's catalogs have since undergone considerable upgrades and changes over the years. Catalogs in the .fdb format that weren't converted in Portfolio 1.x.x can exhibit difficulties in Portfolio 3.x.x
Resolution
For the best results we suggest starting from scratch and rebuilding the catalog by hand. While we understand it can be a big ask, ultimately it's the cleanest and most guaranteed way to move into a modern Portfolio catalog. It is possible to purchase time with our Integration and Consulting Service team to assist with this process.
The other option is to create a template from the .fdb catalog and create a new catalog from that template. Keep in mind that this will not bring over galleries or watchfolders to the new catalog. If the issue persists after using this method we are going to ask that you rebuild the catalog from the ground up.
Creating the Template:
- Login to the Portfolio Admin Portal
- Navigate to the Catalogs Tab
- Highlight the .fdb catalog
- Select "Save Catalog Template..."
- Name the Template and click Save
Before Creating the New Catalog:
Remove the watchfolder from the old catalog (do not check "Remote Assets from Catalog")
Create the new catalog:
- In the Catalog Tab Select "Add New Catalog"
- Click the drop down menu next to "Catalog Template"
- Select the template you created from the .fdb catalog
- Setup the catalog as normal
From there you'll need to setup the new catalog with the correct watchfolder(s) and re-create your galleries. Once you're sure the new catalog is functional and everything has been moved over you can remove the .fdb catalog.