Dieser Artikel ist nicht in Deutsch verfügbar. Durch Aufrufen dieses Artikels unterstützen Sie uns, dessen Übersetzung zukünftig in Betracht zu ziehen.
Falls Sie zusätzliche Unterstützung oder für den Kundendienst relevante Fragen haben, wenden Sie sich bitte an unser deutsches Kundendienst-Team über dieses Formular: https://help.extensis.com/hc/de/requests/new
Problem
Portfolio Server won't remain in "Started" state, user receives "SOAP error (null pointer exception)" or "SOAPFault (Server): java.lang.NullPointerException null" when attempting to login to Portfolio Admin (8091)
Environment
This article covers Portfolio version 3.x and 4 on macOS
Cause
This issue is usually caused by the .preferences file writing incorrectly inside /Library/Application Support/Extensis/Portfolio Server on the server Portfolio is installed on (denoted by a similar display to the below screenshot.) Make sure to un-hide hidden files by pressing cmd+shift+. first
Resolution
1. Open terminal an run the following command:
sudo launchctl unload /Library/LaunchDaemons/com.extensis.dam-server.web.admin.launchd.plist
2. Navigate to /Library/Application Support/Extensis/Portfolio Server
3. Move all current files that are labeled or begin with .preferences files to the desktop (the files are hidden by default, press cmd+shift+. to reveal hidden files)
4. Navigate to a previous Portfolio backup (By default, this is located in /Applications/Extensis/Portfolio Server/data/backups)
5. Open the backup, navigate to the data folder, and copy the .preferences file inside
6. Navigate back to /Library/Application Support/Extensis/Portfolio Server and paste the .preferences inside
7. Open terminal an run the following command:
sudo launchctl load -F /Library/LaunchDaemons/com.extensis.dam-server.web.admin.launchd.plist
If you run into trouble with this process or have additional questions please contact technical support