Problem
Portfolio Server won't remain in "Started" state, user receives "SOAP error (null pointer exception)" or "SOAPFault (Server): java.lang.NullPointerException null" when attempting to login to Portfolio Admin (8091)
Environment
This article covers Portfolio version 3.x and 4 on Windows Server
Cause
This issue is usually caused by the .preferences file writing incorrectly inside C:\ProgramData\Extensis\Portfolio Server on the server Portfolio is installed on (denoted by a similar display to the below screenshot)
Resolution
1. Stop the Portfolio Server, Portfolio Server (Media Engine), and Portfolio Server Admin services (if they are not already)
2. Navigate to C:\ProgramData\Extensis\Portfolio Server
(Note: The folder may be hidden by the OS)
3. Move all current files that are labeled or begin with .preferences files to the desktop
4. Navigate to a previous Portfolio backup (By default, this is located in C:\Program Files (x86)\Extensis\Portfolio Server\data\backups)
5. Open the backup, navigate to the data folder, and copy the .preferences file inside
6. Navigate back to C:\ProgramData\Extensis\Portfolio Server and paste the .preferences inside
7. Restart the Portfolio Server, Portfolio Server (Media Engine), and Portfolio Server Admin services and confirm that you can log into the Portfolio Admin Portal